Statistics Slowdown
Incident Report for NS1
Resolved
This issue has been resolved.
Posted over 1 year ago. Aug 05, 2017 - 00:08 UTC
Identified
Our statistics subsystem is currently experiencing increased load. Query statistics may load slowly in the portal and API.
Posted over 1 year ago. Aug 04, 2017 - 20:02 UTC