NS1 Native Monitoring Service Failures
Incident Report for NS1
Resolved
NS1 engineers have deployed a fix and all monitoring regions have reflected accurate monitor status at this time. No further impact is expected.
Posted 5 months ago. May 31, 2018 - 07:21 UTC
Monitoring
This incident has been further isolated to the Amsterdam (AMS) region for HTTP monitors, meaning that all jobs sourcing from 3 regions or more with the "Quorum" or "All" policy in place will reflect an accurate "GLOBAL" monitor status.

DNS records that have answers connected to monitors with this configuration have been showing no signs of impact since 19:35 UTC, though NS1 engineers are continuing to monitor this closely. We are still working diligently to resolve the issue impacting the AMS region and will provide further updates as we progress toward resolution.
Posted 5 months ago. May 30, 2018 - 20:48 UTC
Update
NS1 engineers have contained the issue to jobs of type HTTP in the following regions: Amsterdam (AMS), Singapore (SIN) and San Jose (SJC). We continue to advise disabling the "UP" filter until the incident is completely resolved. Updates will be posted here as we progress in resolving this issue.
Posted 5 months ago. May 30, 2018 - 18:30 UTC
Update
NS1 engineers are still working to resolve the issue. In the meantime, we encourage users with records affected by this incident to disable the "UP" filter in the record's Filter Chain to avoid having DNS answers altered by the incorrect monitoring statuses.
Posted 5 months ago. May 30, 2018 - 17:45 UTC
Investigating
We are currently investigating an issue with our monitoring subsystem that may be causing some monitoring jobs to incorrectly report a DOWN status across multiple regions. Though DNS deliverability is unaffected, this may alter which answer(s) the Filter Chain returns, depending on the monitoring policy in place. We are actively working to resolve the issue.
Posted 5 months ago. May 30, 2018 - 16:50 UTC
This incident affected: Monitoring Jobs.